summaryrefslogtreecommitdiff
path: root/app/drivers/sensor/battery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/drivers/sensor/battery/CMakeLists.txt')
-rw-r--r--app/drivers/sensor/battery/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/app/drivers/sensor/battery/CMakeLists.txt b/app/drivers/sensor/battery/CMakeLists.txt
new file mode 100644
index 0000000..1203e53
--- /dev/null
+++ b/app/drivers/sensor/battery/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Copyright (c) 2020-2021 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+
+zephyr_include_directories(.)
+
+zephyr_library()
+
+zephyr_library_sources(battery_common.c)
+zephyr_library_sources_ifdef(CONFIG_ZMK_BATTERY_NRF_VDDH battery_nrf_vddh.c)
+zephyr_library_sources_ifdef(CONFIG_ZMK_BATTERY_VOLTAGE_DIVIDER battery_voltage_divider.c) \ No newline at end of file