summaryrefslogtreecommitdiff
path: root/app/drivers/gpio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/drivers/gpio/CMakeLists.txt')
-rw-r--r--app/drivers/gpio/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/app/drivers/gpio/CMakeLists.txt b/app/drivers/gpio/CMakeLists.txt
new file mode 100644
index 0000000..b879b23
--- /dev/null
+++ b/app/drivers/gpio/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Copyright (c) 2020 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+
+zephyr_library_named(zmk__drivers__gpio)
+zephyr_library_include_directories(${CMAKE_SOURCE_DIR}/include)
+
+zephyr_library_sources_ifdef(CONFIG_GPIO_MCP23017 gpio_mcp23017.c)
+zephyr_library_sources_ifndef(CONFIG_GPIO_MCP23017 ${ZEPHYR_BASE}/misc/empty_file.c)