summaryrefslogtreecommitdiff
path: root/app/drivers/gpio/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2021-01-28 22:54:44 -0500
committerPete Johanson <peter@peterjohanson.com>2021-09-14 20:48:28 -0400
commit647110e5e5adef98a133f5f65b212110e614309b (patch)
tree2295ff9a2135fc495db41da977459b1a86f19380 /app/drivers/gpio/CMakeLists.txt
parent2f0ad4cc8c7c4a4b0344206bce638a8241b85b95 (diff)
feat(drivers): Add mcp23017 driver based on upstream mcp23s17 one.
* Upstream Zephyr has in progress driver, so doing this locally here, until we can move over to that driver.
Diffstat (limited to 'app/drivers/gpio/CMakeLists.txt')
-rw-r--r--app/drivers/gpio/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/app/drivers/gpio/CMakeLists.txt b/app/drivers/gpio/CMakeLists.txt
new file mode 100644
index 0000000..b879b23
--- /dev/null
+++ b/app/drivers/gpio/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Copyright (c) 2020 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+
+zephyr_library_named(zmk__drivers__gpio)
+zephyr_library_include_directories(${CMAKE_SOURCE_DIR}/include)
+
+zephyr_library_sources_ifdef(CONFIG_GPIO_MCP23017 gpio_mcp23017.c)
+zephyr_library_sources_ifndef(CONFIG_GPIO_MCP23017 ${ZEPHYR_BASE}/misc/empty_file.c)