summaryrefslogtreecommitdiff
path: root/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-05-26 20:48:15 -0400
committerPete Johanson <peter@peterjohanson.com>2020-05-26 20:48:15 -0400
commit72ad47e0275c0035aa9ea04ee6127a14bbe50b65 (patch)
treef6f862bb23a4a175c0a54d2c89d0ecdc4a45346e /drivers/zephyr/CMakeLists.txt
parentdfd5bc0586b6201d7fef279b0cc6248fd5a3558c (diff)
Initial import of GPIO kscan driver into ZMK.
Diffstat (limited to 'drivers/zephyr/CMakeLists.txt')
-rw-r--r--drivers/zephyr/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/drivers/zephyr/CMakeLists.txt b/drivers/zephyr/CMakeLists.txt
new file mode 100644
index 0000000..03a97c6
--- /dev/null
+++ b/drivers/zephyr/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
+ # Add hello_world_driver.h to the set of global include paths.
+ zephyr_include_directories(.)
+
+ zephyr_library()
+ zephyr_library_sources(
+ kscan_gpio.c
+ )
+endif()