summaryrefslogtreecommitdiff
path: root/app/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorinnovaker <66737976+innovaker@users.noreply.github.com>2020-11-19 17:20:43 +0000
committerPete Johanson <peter@peterjohanson.com>2020-12-03 21:06:01 -0500
commit8d9ae1fdf379020d4743b4f85f465e88b148ac29 (patch)
tree07cb741277cc5a85a66c280f258d551690c120e7 /app/drivers/zephyr/CMakeLists.txt
parent177b28f01de88ece582604c0ef0abaaaefe2f624 (diff)
refactor: Align drivers with Zephyr file system conventions
PR: #400
Diffstat (limited to 'app/drivers/zephyr/CMakeLists.txt')
-rw-r--r--app/drivers/zephyr/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/app/drivers/zephyr/CMakeLists.txt b/app/drivers/zephyr/CMakeLists.txt
deleted file mode 100644
index e3a192d..0000000
--- a/app/drivers/zephyr/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
- zephyr_include_directories(.)
-
- zephyr_library()
- zephyr_library_sources(
- kscan_gpio_matrix.c
- kscan_gpio_direct.c
- kscan_gpio_demux.c
- )
-
- zephyr_library_sources_ifdef(CONFIG_EC11 ec11.c)
- zephyr_library_sources_ifdef(CONFIG_EC11_TRIGGER ec11_trigger.c)
- zephyr_library_sources_ifdef(CONFIG_ZMK_BATTERY_VOLTAGE_DIVIDER battery_voltage_divider.c)
-endif()