summaryrefslogtreecommitdiff
path: root/app/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-07-21 14:38:32 -0400
committerGitHub <noreply@github.com>2020-07-21 14:38:32 -0400
commit54f1ddc1f5bbe19c0a669937d85c71153a859116 (patch)
tree20eeb2aacdebb7180d28ffb2c2da02191d7da1ed /app/drivers/zephyr/CMakeLists.txt
parent22c0558b2f9561f2bebae4646eb41800c3fe0cc8 (diff)
parent3a508c42d0f408b42e58f119f4f0132a87203ad1 (diff)
Merge pull request #59 from petejohanson/sensors/en11-encoder-sensor
Initial low level EC11 sensor driver
Diffstat (limited to 'app/drivers/zephyr/CMakeLists.txt')
-rw-r--r--app/drivers/zephyr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/app/drivers/zephyr/CMakeLists.txt b/app/drivers/zephyr/CMakeLists.txt
index 983828f..8778ded 100644
--- a/app/drivers/zephyr/CMakeLists.txt
+++ b/app/drivers/zephyr/CMakeLists.txt
@@ -6,4 +6,7 @@ if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
kscan_gpio_matrix.c
kscan_gpio_direct.c
)
+
+ zephyr_library_sources_ifdef(CONFIG_EC11 ec11.c)
+ zephyr_library_sources_ifdef(CONFIG_EC11_TRIGGER ec11_trigger.c)
endif()