summaryrefslogtreecommitdiff
path: root/app/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-06-08 21:07:16 -0400
committerPete Johanson <peter@peterjohanson.com>2020-06-08 21:07:16 -0400
commit38f1dbd9842eaf53db359ad46b070bfff8db1359 (patch)
tree6a24845fab2043cd0cec8b2086971ff13edeed70 /app/drivers/zephyr/CMakeLists.txt
parent92b41d28e5668fab4fe423ccce5f3f85b4537002 (diff)
Move Zephyr app into subdirectory.
Diffstat (limited to 'app/drivers/zephyr/CMakeLists.txt')
-rw-r--r--app/drivers/zephyr/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/app/drivers/zephyr/CMakeLists.txt b/app/drivers/zephyr/CMakeLists.txt
new file mode 100644
index 0000000..03a97c6
--- /dev/null
+++ b/app/drivers/zephyr/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
+ # Add hello_world_driver.h to the set of global include paths.
+ zephyr_include_directories(.)
+
+ zephyr_library()
+ zephyr_library_sources(
+ kscan_gpio.c
+ )
+endif()