summaryrefslogtreecommitdiff
path: root/app/drivers/sensor/ec11/CMakeLists.txt
diff options
context:
space:
mode:
authorinnovaker <66737976+innovaker@users.noreply.github.com>2020-11-19 17:20:43 +0000
committerPete Johanson <peter@peterjohanson.com>2020-12-03 21:06:01 -0500
commit8d9ae1fdf379020d4743b4f85f465e88b148ac29 (patch)
tree07cb741277cc5a85a66c280f258d551690c120e7 /app/drivers/sensor/ec11/CMakeLists.txt
parent177b28f01de88ece582604c0ef0abaaaefe2f624 (diff)
refactor: Align drivers with Zephyr file system conventions
PR: #400
Diffstat (limited to 'app/drivers/sensor/ec11/CMakeLists.txt')
-rw-r--r--app/drivers/sensor/ec11/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/app/drivers/sensor/ec11/CMakeLists.txt b/app/drivers/sensor/ec11/CMakeLists.txt
new file mode 100644
index 0000000..de291fe
--- /dev/null
+++ b/app/drivers/sensor/ec11/CMakeLists.txt
@@ -0,0 +1,9 @@
+# Copyright (c) 2020 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+
+zephyr_include_directories(.)
+
+zephyr_library()
+
+zephyr_library_sources(ec11.c)
+zephyr_library_sources_ifdef(CONFIG_EC11_TRIGGER ec11_trigger.c) \ No newline at end of file