summaryrefslogtreecommitdiff
path: root/app/boards/arm/nice60/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Winans <nick@winans.codes>2021-05-29 10:00:40 -0500
committerPete Johanson <peter@peterjohanson.com>2021-05-30 11:47:20 -0400
commit3f838f0aaf90cd5f8dad622fd1d901a9a8eb40d0 (patch)
tree96609a1b216a072799c6032d7b7462294969832b /app/boards/arm/nice60/CMakeLists.txt
parenta32cd668d6c793ee77c4d85ce5fb47e793f8ae11 (diff)
feat(boards): Add nice!60 board
Diffstat (limited to 'app/boards/arm/nice60/CMakeLists.txt')
-rw-r--r--app/boards/arm/nice60/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/app/boards/arm/nice60/CMakeLists.txt b/app/boards/arm/nice60/CMakeLists.txt
new file mode 100644
index 0000000..f833ff2
--- /dev/null
+++ b/app/boards/arm/nice60/CMakeLists.txt
@@ -0,0 +1,8 @@
+set_property(GLOBAL APPEND PROPERTY extra_post_build_commands
+ COMMAND ${PYTHON_EXECUTABLE} ${ZEPHYR_BASE}/../tools/uf2/utils/uf2conv.py
+ -c
+ -b 0x1000
+ -f 0xADA52840
+ -o ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.uf2
+ ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.bin
+)