summaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-10-02 02:09:38 -0400
committerPete Johanson <peter@peterjohanson.com>2020-10-06 17:24:36 -0400
commita7496ab06425cab7de5fc7164b4ce5a34dd7107b (patch)
tree996b25361b7ef6d006c9f3b949562efda57a77c8 /app/CMakeLists.txt
parent9be566603e2eb248fbaa7af65cba42d5c06dbd33 (diff)
feat(power): Initial deep sleep work.
* New ZMK_SLEEP Kconfig symbol to enable the functionality. * Switch to PORT events that allows wake from deep sleep. * Initial basic power management policy, with idle ms, and ignoring deep sleep if we detect a USB connection.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 5c77c54..3e59d75 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -23,6 +23,7 @@ zephyr_linker_sources(RODATA include/linker/zmk-events.ld)
# Add your source file to the "app" target. This must come after
# find_package(Zephyr) which defines the target.
target_include_directories(app PRIVATE include)
+target_sources_ifdef(CONFIG_ZMK_SLEEP app PRIVATE src/power.c)
target_sources(app PRIVATE src/kscan.c)
target_sources(app PRIVATE src/matrix_transform.c)
target_sources(app PRIVATE src/hid.c)