summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-05-18 13:42:41 -0400
committerPete Johanson <peter@peterjohanson.com>2020-05-18 13:42:41 -0400
commitf478438f01e081514f255ce67f7b75935ee7b51a (patch)
tree22595d1f285d5937af3f93cc752ff2feee5e26fd /CMakeLists.txt
parentc1905745b3578037d1791bd634a3d1607cafd525 (diff)
Implement raise/lower for default keymap.
* Properly allow includes for keymaps to allow defining custom keycodes, and then adding them to the keymap.overlay file. * Fix keymap.c loading after build refactor. * Fix for deactivating a layer working properly. * Fix default keymap to put transparent in proper spots to make raise/lower keycodes work as expected. * Add custom raise/lower keycode handling to default keymap.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9348b9c..3bc1b28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,9 +9,9 @@ include(cmake/keymap.cmake)
find_package(Zephyr)
project(zmk)
-if(EXISTS ${KEYMAP_DIR}/${KEYMAP}/keymap.c)
+if(EXISTS ${KEYMAP_DIR}/keymap.c)
message(STATUS "ADDING THE KEYMAP SOURCE")
- target_sources(app PRIVATE ${KEYMAP_DIR}/${KEYMAP}/keymap.c)
+ target_sources(app PRIVATE ${KEYMAP_DIR}/keymap.c)
endif()