summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-05-05 16:09:05 -0400
committerPete Johanson <peter@peterjohanson.com>2020-05-05 16:09:05 -0400
commita63a773983e8e575778ba2e3b326b3f2e63ce26e (patch)
treea61249a25554e95062334b72e3f5e6706dcaa1e9 /CMakeLists.txt
parentfe961d54a351a793c9037f78a42ae07eddec7d69 (diff)
Get *basic* USB report sending working.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c2e065..da0d9d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,7 @@
cmake_minimum_required(VERSION 3.13.1)
list(APPEND BOARD_ROOT ${CMAKE_SOURCE_DIR})
+list(APPEND DTS_ROOT ${CMAKE_SOURCE_DIR})
find_package(Zephyr)
project(zmk)
@@ -10,5 +11,6 @@ project(zmk)
# find_package(Zephyr) which defines the target.
target_sources(app PRIVATE src/kscan.c)
target_sources(app PRIVATE src/keymap.c)
+target_sources(app PRIVATE src/usb_hid.c)
target_sources(app PRIVATE src/main.c)