summaryrefslogtreecommitdiff
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
new file mode 100644
index 0000000..a45320f
--- /dev/null
+++ b/hardware-configuration.nix
@@ -0,0 +1,30 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/profiles/qemu-guest.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/5e5668c1-6227-4e75-82e5-56072a8efb3b";
+ fsType = "ext4";
+ };
+
+ fileSystems."/mnt/remote" =
+ { device = "/dev/disk/by-uuid/8b4d81d3-94ef-4592-81a5-233d34b29359";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/9bf7dfac-5e8c-4829-bfb8-6ff9a45e4803"; }
+ ];
+
+}