summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Palus <jan.palus@gmail.com>2010-08-17 17:37:47 +0200
committerAndrzej Rybczak <electricityispower@gmail.com>2010-08-22 15:34:28 +0200
commit6cc12a8da6746aa3c575eedc7a60a42d312ffa64 (patch)
treee614be6b7b47fad5afa9be78b0e68602972b70bd /configure.in
parente0eff99175ae957b2cd9a16faa04b532514c08a5 (diff)
configure: check for ncurses config with abi 6
Signed-off-by: Jan Palus <jan.palus@gmail.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8d37378f..8e66e688 100644
--- a/configure.in
+++ b/configure.in
@@ -101,10 +101,10 @@ dnl = checking for ncurses =
dnl ========================
if test "$pdcurses" = "no" ; then
if test "$unicode" = "yes" ; then
- curses_config_bin=ncursesw5-config
+ curses_config_bin="ncursesw6-config ncursesw5-config"
AC_DEFINE([_UTF8], [1], [enables unicode support])
else
- curses_config_bin=ncurses5-config
+ curses_config_bin="ncurses6-config ncurses5-config"
fi
else
if test "$pdcurses" = "yes" ; then
@@ -115,7 +115,7 @@ else
fi
AC_DEFINE([USE_PDCURSES], [1], [enables pdcurses support])
fi
-AC_PATH_PROG(CURSES_CONFIG, $curses_config_bin)
+AC_PATH_PROGS(CURSES_CONFIG, $curses_config_bin)
if test "$CURSES_CONFIG" != "" ; then
CPPFLAGS="$CPPFLAGS `$CURSES_CONFIG --cflags`"
LDFLAGS="$LDFLAGS `$CURSES_CONFIG --libs`"