summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrzej Rybczak <electricityispower@gmail.com>2009-09-21 17:37:06 +0200
committerAndrzej Rybczak <electricityispower@gmail.com>2009-09-21 17:37:06 +0200
commit0a1d2e37ae17d8888e515b52cc7dd30c71e56a6f (patch)
treecf5711b2a6cb66b4a867bfce8e78c658b7c8bdbc /configure.in
parent70910b77ed191d1c39526c70fd0ecd91bad5b4b1 (diff)
add -fno-exceptions to CXXFLAGS if compiler supports it
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 693de9cb..6fe9dccc 100644
--- a/configure.in
+++ b/configure.in
@@ -28,6 +28,21 @@ if test "$clock" = "yes"; then
AC_DEFINE([ENABLE_CLOCK], [1], [enables clock screen])
fi
+dnl =====================================
+dnl = checking for -fno-exceptions flag =
+dnl =====================================
+AC_MSG_CHECKING([whether compiler supports -fno-exceptions])
+old_CXXFLAGS="$CXXFLAGS"
+CXXFLAGS="-fno-exceptions"
+AC_COMPILE_IFELSE(AC_LANG_PROGRAM([[ ]]),
+ AC_MSG_RESULT([yes])
+ no_exceptions="-fno-exceptions"
+ ,
+ AC_MSG_RESULT([no])
+)
+CXXFLAGS="$old_CXXFLAGS $no_exceptions"
+
+
dnl ====================================
dnl = checking for win32 related stuff =
dnl ====================================