summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej Rybczak <electricityispower@gmail.com>2015-05-14 23:09:36 +0200
committerAndrzej Rybczak <electricityispower@gmail.com>2015-05-14 23:09:36 +0200
commitc53e98e2a579618aa4694afd87fbbc9a84f4e9da (patch)
tree7901991c922c70b82ed542fb747333d65feebd0e /configure.ac
parent235001a5fc0eb7811e3aca8ed7d27c69e20799e0 (diff)
configure: require readline/readline.h and pthread.h headers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 492f95b5..d42d881c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -227,6 +227,7 @@ AC_CHECK_HEADERS([readline/readline.h readline/history.h],
AC_CHECK_LIB(readline, rl_initialize, LIBS="$LIBS -lreadline",
AC_MSG_ERROR([readline headers found but there is no readline library to make use of])
),
+ AC_MSG_ERROR([no readline/readline.h header file found])
)
@@ -237,6 +238,7 @@ AC_CHECK_HEADERS([pthread.h],
AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread",
AC_MSG_ERROR([pthread.h found but there is no pthread library to make use of])
),
+ AC_MSG_ERROR([no pthread.h header header file found])
)
dnl ========================