summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index f20a79aa0..a1dc7840d 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -336,6 +336,11 @@ if curl_dep.found()
include_directories: inc,
dependencies: [
curl_dep,
+
+ # Explicitly linking with zlib here works around a linker
+ # failure on Windows, because our Windows CURL build is
+ # statically linked and thus declares no dependency on zlib
+ zlib_dep,
],
)