summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build19
1 files changed, 6 insertions, 13 deletions
diff --git a/test/meson.build b/test/meson.build
index 0f01aca3e..e3f2a6fa6 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -24,6 +24,7 @@ gtest_dep = declare_dependency(
)
subdir('net')
+subdir('time')
executable(
'read_conf',
@@ -52,19 +53,6 @@ test('TestUtil', executable(
],
))
-test(
- 'TestTime',
- executable(
- 'TestTime',
- 'TestISO8601.cxx',
- include_directories: inc,
- dependencies: [
- time_dep,
- gtest_dep,
- ],
- ),
-)
-
test('TestRewindInputStream', executable(
'TestRewindInputStream',
'TestRewindInputStream.cxx',
@@ -326,6 +314,11 @@ if curl_dep.found()
include_directories: inc,
dependencies: [
curl_dep,
+
+ # Explicitly linking with zlib here works around a linker
+ # failure on Windows, because our Windows CURL build is
+ # statically linked and thus declares no dependency on zlib
+ zlib_dep,
],
)