summaryrefslogtreecommitdiff
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorJohn Regan <john@jrjrtech.com>2021-05-15 10:16:49 -0400
committerJohn Regan <john@jrjrtech.com>2021-05-15 11:31:01 -0400
commit87fa6bca544722550424404b19594f465a391374 (patch)
treef2f06b8b42ad0e80d0005ec59c245d6b6a655b93 /src/util/meson.build
parentc3226a319510a7ac57d6e88363a32780eb099888 (diff)
flac encoder: enable Ogg FLAC and Ogg chaining
refactors GenerateOggSerial into a generic GenerateSerial utility, under the util lib. libFLAC may be encoded without Ogg support. If Ogg support is disabled, libFLAC will still export Ogg-related methods (like setting a serial number), and throw a runtime error when initializing an Ogg stream. GenerateOggSerial does not depend on libogg. Refactoring it into a generic GenerateSerial prevents having to add build-time checks for libogg within the FLAC encoder plugin.
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index dc37588cb..953296e5c 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -29,6 +29,7 @@ util = static_library(
'ByteReverse.cxx',
'format.c',
'BitReverse.cxx',
+ 'Serial.cxx',
include_directories: inc,
)