summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2020-05-05 15:08:55 +0200
committerMax Kellermann <max@musicpd.org>2020-05-05 15:12:11 +0200
commite0edf0b206549f68a03d69c2ba5b4cd3d4105a1f (patch)
tree6cf8f08ca0743e7b6b8ecab67ec63c8d1c163c7c /meson.build
parent4e9fa36176ac3a8c9d2acf68f7ec0931d8350a09 (diff)
meson.build: move VERSION and others to Version.h
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 7 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index d1ff992c3..c4ba8a8c6 100644
--- a/meson.build
+++ b/meson.build
@@ -21,11 +21,14 @@ elif compiler.get_id() == 'clang' and compiler.version().version_compare('<4')
warning('Your clang version is too old. You need at least version 4.')
endif
+version_conf = configuration_data()
+version_conf.set_quoted('PACKAGE', meson.project_name())
+version_conf.set_quoted('PACKAGE_NAME', meson.project_name())
+version_conf.set_quoted('VERSION', meson.project_version())
+version_conf.set_quoted('PROTOCOL_VERSION', '0.22.0')
+configure_file(output: 'Version.h', configuration: version_conf)
+
conf = configuration_data()
-conf.set_quoted('PACKAGE', meson.project_name())
-conf.set_quoted('PACKAGE_NAME', meson.project_name())
-conf.set_quoted('VERSION', meson.project_version())
-conf.set_quoted('PROTOCOL_VERSION', '0.22.0')
conf.set_quoted('SYSTEM_CONFIG_FILE_LOCATION', join_paths(get_option('prefix'), get_option('sysconfdir'), 'mpd.conf'))
common_cppflags = [