summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2019-11-04 14:12:07 +0100
committerMax Kellermann <max@musicpd.org>2019-11-04 14:15:48 +0100
commitbea3b954a53418d820b8e59b7258fc9f637b18ca (patch)
tree96810399b571bf2d3503f9cd91ec0f70dfd96cc1 /meson.build
parent129d8e89b9189d88e4da970ed642f4b9ca731574 (diff)
meson.build, SongUpdate: disable db-specific archive code if -Ddatabase=false
Fixes another build failure.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8c04c0574..e18e7d6bf 100644
--- a/meson.build
+++ b/meson.build
@@ -385,8 +385,11 @@ endif
if archive_glue_dep.found()
sources += [
'src/TagArchive.cxx',
- 'src/db/update/Archive.cxx',
]
+
+ if enable_database
+ sources += ['src/db/update/Archive.cxx']
+ endif
endif
if is_windows