summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2020-05-07 12:41:40 +0200
committerMax Kellermann <max@musicpd.org>2020-05-07 15:04:50 +0200
commita24ef280cc3a97736d5ef47fb7766825786d7a52 (patch)
tree3d0361eadf9a254fa0016ba3531365ce4b50040b /meson.build
parentd1d6a3871e678d894a371cf3dea75026e91e801d (diff)
meson.build: require GCC 8 or clang 5
Commit 60f957ed648 broken the GCC 7 build, but instead of working around missing C++17 features in old compilers, let's update the compiler version requirements. This commit raises the clang requirement to version 5 because this is the first version to support `constexpr` lambdas, to be used to `Dsd2Pcm.cxx`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index e78693ace..085b97bbc 100644
--- a/meson.build
+++ b/meson.build
@@ -15,10 +15,10 @@ version_cxx = vcs_tag(input: 'src/GitVersion.cxx', output: 'GitVersion.cxx')
compiler = meson.get_compiler('cpp')
c_compiler = meson.get_compiler('c')
-if compiler.get_id() == 'gcc' and compiler.version().version_compare('<7')
- warning('Your GCC version is too old. You need at least version 7.')
-elif compiler.get_id() == 'clang' and compiler.version().version_compare('<4')
- warning('Your clang version is too old. You need at least version 4.')
+if compiler.get_id() == 'gcc' and compiler.version().version_compare('<8')
+ warning('Your GCC version is too old. You need at least version 8.')
+elif compiler.get_id() == 'clang' and compiler.version().version_compare('<5')
+ warning('Your clang version is too old. You need at least version 5.')
endif
version_conf = configuration_data()