summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2020-09-23 15:13:10 +0200
committerMax Kellermann <max@musicpd.org>2020-09-23 15:13:19 +0200
commit5492304254c86f3a187d728e29afb7d43965c896 (patch)
tree369a0f19130efdbaefee57634bd26342a13654b1 /meson.build
parent416d4e44330086268b6ed40dfb1e918861017e56 (diff)
meson.build: drop obsolete warning flag -Wno-noexcept-type
We don't support GCC 7 anymore.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 98318db20..8fa9dd4b3 100644
--- a/meson.build
+++ b/meson.build
@@ -77,11 +77,6 @@ test_cxxflags = test_common_flags + [
'-Wused-but-marked-unused',
'-Wno-non-virtual-dtor',
-
- # work around bogus GCC7 warning "mangled name for ... will change
- # in C++17 because the exception specification is part of a function
- # type"
- '-Wno-noexcept-type',
]
if compiler.get_id() == 'clang'