summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2016-12-13 10:59:23 +0100
committerMax Kellermann <max@musicpd.org>2016-12-13 11:00:39 +0100
commit99659e4cf9ea67dc4b9a1dc0202d8ca3b51edbcd (patch)
tree17199e06ff893643f5fa274d81346c7c23aca18e /configure.ac
parentdc05dd7ca146a9aa9bf7c05f0563b20c23ab0af4 (diff)
parent3bbcda917ce7cb2fa6dcc90d6c38333ca855c941 (diff)
Merge tag 'v0.19.21'
release v0.19.21
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4ac95b20..d420e572c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,22 @@ if test "x$with_systemdsystemunitdir" != xno; then
fi
AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
+AC_ARG_WITH([systemduserunitdir],
+ AS_HELP_STRING([--with-systemduserunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemduserunitdir=no])
+if test "x$with_systemduserunitdir" = xyes; then
+ AC_MSG_CHECKING(for systemd)
+ with_systemduserunitdir=$($PKG_CONFIG --variable=systemduserunitdir systemd)
+ if test -z "$with_systemduserunitdir"; then
+ AC_MSG_ERROR([Failed to detect systemd])
+ fi
+ AC_MSG_RESULT([$with_systemduserunitdir])
+fi
+if test "x$with_systemduserunitdir" != xno; then
+ AC_SUBST([systemduserunitdir], [$with_systemduserunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD_USER, [test -n "$with_systemduserunitdir" -a "x$with_systemduserunitdir" != xno ])
+
dnl ---------------------------------------------------------------------------
dnl Declare Variables
dnl ---------------------------------------------------------------------------
@@ -1498,7 +1514,8 @@ dnl Generate files
dnl ---------------------------------------------------------------------------
AC_CONFIG_FILES(Makefile)
AC_CONFIG_FILES(doc/doxygen.conf)
-AC_CONFIG_FILES(systemd/mpd.service)
+AC_CONFIG_FILES(systemd/system/mpd.service)
+AC_CONFIG_FILES(systemd/user/mpd.service)
AC_OUTPUT
echo 'MPD is ready for compilation, type "make" to begin.'