summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-06-03 11:03:49 +0200
committerMax Kellermann <max@musicpd.org>2018-06-04 22:00:52 +0200
commitba8040d0687aeb5327948d97641be9d7608f1027 (patch)
treef1796c41242cad4f09e663697a64cfa7573a2aa9 /Makefile.am
parent5fa94d2a853d67a9a7b93f934c3a2eeae6bd2726 (diff)
storage/udisks: new plugin
Documentation will follow soon.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1550576ec..29e1b9dd6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -792,6 +792,7 @@ libstorage_a_SOURCES = \
src/storage/FileInfo.hxx
libstorage_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(DBUS_CFLAGS) \
$(NFS_CFLAGS) \
$(SMBCLIENT_CFLAGS)
@@ -802,6 +803,14 @@ STORAGE_LIBS = \
$(NFS_LIBS) \
$(SMBCLIENT_LIBS)
+if ENABLE_UDISKS
+libstorage_a_SOURCES += \
+ src/storage/plugins/UdisksStorage.cxx src/storage/plugins/UdisksStorage.hxx
+STORAGE_LIBS += \
+ $(DBUS_LIBS) \
+ libodbus.a
+endif
+
if ENABLE_SMBCLIENT
libstorage_a_SOURCES += \
$(SMBCLIENT_SOURCES) \