summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2016-12-13 08:41:55 +0100
committerMax Kellermann <max@musicpd.org>2016-12-13 10:24:10 +0100
commitab332d7b2eb6ebc1052885bdcebac9c2673a7dde (patch)
tree6a7662d989fd522726de0c36dfa5cd2a826f2fc8 /Makefile.am
parent53e22b81ef026e873c992bca35e27b41580a0bf8 (diff)
systemd: add user unit
The user unit omits the "ProtectKernelModules" setting which fails with modular kernels: Failed at step CAPABILITIES spawning /usr/bin/mpd: Operation not permitted It is unfortunate that systemd (version 232) is unable to reduce its own capabilities, because this requires us to split system and user units. https://bugs.musicpd.org/view.php?id=4608
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 029958adb..ec1bb0bbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1453,6 +1453,11 @@ systemdsystemunit_DATA = \
systemd/system/mpd.service
endif
+if HAVE_SYSTEMD_USER
+systemduserunit_DATA = \
+ systemd/user/mpd.service
+endif
+
#
# Test programs