summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2017-02-08 19:35:27 +0100
committerMax Kellermann <max@musicpd.org>2017-02-09 21:24:24 +0100
commit9e503b21c1d7bd2288bd8834ffd437b9c2200825 (patch)
tree3ec341198e177a60b638e947cc4f7d37ce319b64 /Makefile.am
parent67a958a3262d37892a5043fc6216c1d8d9f65b1c (diff)
{input,mixer}/alsa: move code to lib/alsa/NonBlock.cxx
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 72628ce9a..3df7fa2f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -256,6 +256,9 @@ UPNP_SOURCES = \
src/lib/upnp/WorkQueue.hxx \
src/lib/upnp/Action.hxx
+ALSA_SOURCES = \
+ src/lib/alsa/NonBlock.cxx src/lib/alsa/NonBlock.hxx
+
#
# Android native library
#
@@ -1294,6 +1297,7 @@ INPUT_LIBS = \
if ENABLE_ALSA
libinput_a_SOURCES += \
+ $(ALSA_SOURCES) \
src/input/plugins/AlsaInputPlugin.cxx \
src/input/plugins/AlsaInputPlugin.hxx
INPUT_LIBS += $(ALSA_LIBS)
@@ -1412,6 +1416,7 @@ liboutput_plugins_a_SOURCES += \
src/output/plugins/AlsaOutputPlugin.cxx \
src/output/plugins/AlsaOutputPlugin.hxx
libmixer_plugins_a_SOURCES += \
+ $(ALSA_SOURCES) \
src/mixer/plugins/volume_mapping.h \
src/mixer/plugins/volume_mapping.c \
src/mixer/plugins/AlsaMixerPlugin.cxx