summaryrefslogtreecommitdiff
path: root/app/drivers/kscan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/drivers/kscan/CMakeLists.txt')
-rw-r--r--app/drivers/kscan/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/app/drivers/kscan/CMakeLists.txt b/app/drivers/kscan/CMakeLists.txt
new file mode 100644
index 0000000..19933aa
--- /dev/null
+++ b/app/drivers/kscan/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Copyright (c) 2020 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+
+zephyr_library()
+
+zephyr_library_sources_ifdef(CONFIG_ZMK_KSCAN_GPIO_DRIVER kscan_gpio_matrix.c)
+zephyr_library_sources_ifdef(CONFIG_ZMK_KSCAN_GPIO_DRIVER kscan_gpio_direct.c)
+zephyr_library_sources_ifdef(CONFIG_ZMK_KSCAN_GPIO_DRIVER kscan_gpio_demux.c) \ No newline at end of file