summaryrefslogtreecommitdiff
path: root/app/boards/arm/planck/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/boards/arm/planck/CMakeLists.txt')
-rw-r--r--app/boards/arm/planck/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/app/boards/arm/planck/CMakeLists.txt b/app/boards/arm/planck/CMakeLists.txt
new file mode 100644
index 0000000..f26de66
--- /dev/null
+++ b/app/boards/arm/planck/CMakeLists.txt
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: Apache-2.0
+
+list(APPEND EXTRA_DTC_FLAGS "-qq")
+
+if(CONFIG_PINMUX)
+zephyr_library()
+zephyr_library_sources(pinmux.c)
+zephyr_library_include_directories(${ZEPHYR_BASE}/drivers)
+endif()