summaryrefslogtreecommitdiff
path: root/app/boards/arm/nrfmicro/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/boards/arm/nrfmicro/CMakeLists.txt')
-rw-r--r--app/boards/arm/nrfmicro/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/app/boards/arm/nrfmicro/CMakeLists.txt b/app/boards/arm/nrfmicro/CMakeLists.txt
new file mode 100644
index 0000000..cd4843a
--- /dev/null
+++ b/app/boards/arm/nrfmicro/CMakeLists.txt
@@ -0,0 +1,14 @@
+set_property(GLOBAL APPEND PROPERTY extra_post_build_commands
+ COMMAND ${PYTHON_EXECUTABLE} ${ZEPHYR_BASE}/../tools/uf2/utils/uf2conv.py
+ -c
+ -b 0x26000
+ -f 0xADA52840
+ -o ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.uf2
+ ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.bin
+)
+
+if(CONFIG_PINMUX)
+zephyr_library()
+zephyr_library_sources(pinmux.c)
+zephyr_library_include_directories(${ZEPHYR_BASE}/drivers)
+endif() \ No newline at end of file