summaryrefslogtreecommitdiff
path: root/app/boards/arm/nrf52840_m2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/boards/arm/nrf52840_m2/CMakeLists.txt')
-rw-r--r--app/boards/arm/nrf52840_m2/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/app/boards/arm/nrf52840_m2/CMakeLists.txt b/app/boards/arm/nrf52840_m2/CMakeLists.txt
new file mode 100644
index 0000000..84b2ab9
--- /dev/null
+++ b/app/boards/arm/nrf52840_m2/CMakeLists.txt
@@ -0,0 +1,13 @@
+#
+# Copyright (c) 2020 The ZMK Contributors
+# SPDX-License-Identifier: MIT
+#
+
+set_property(GLOBAL APPEND PROPERTY extra_post_build_commands
+ COMMAND ${PYTHON_EXECUTABLE} ${ZEPHYR_BASE}/../tools/uf2/utils/uf2conv.py
+ -c
+ -b 0x26000
+ -f 0xADA52840
+ -o ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.uf2
+ ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.bin
+)