summaryrefslogtreecommitdiff
path: root/app/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-06-24 10:06:35 -0400
committerPete Johanson <peter@peterjohanson.com>2020-06-24 10:14:27 -0400
commitd35a95c7afc9e5ef6f087034dbf4cbb03048f9cd (patch)
treecc5b179646d8a293f4656947c463fd58e41499e2 /app/drivers/zephyr/CMakeLists.txt
parent23931aa4fede2d81437a01e5d69329157219c2a5 (diff)
Initial working Clueboard California Macropad w/ proton-c fixes
* Basic Clueboard Californai Macropad shield definition. * New "direct" KSCAN driver that supports non-matrix direct wiring for switches, needed for macropad that doesn't have a matrix at all. * Some renames for existing KSCAN GPIO driver to make the implied "matrix" part explicit.
Diffstat (limited to 'app/drivers/zephyr/CMakeLists.txt')
-rw-r--r--app/drivers/zephyr/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/app/drivers/zephyr/CMakeLists.txt b/app/drivers/zephyr/CMakeLists.txt
index 03a97c6..b40498f 100644
--- a/app/drivers/zephyr/CMakeLists.txt
+++ b/app/drivers/zephyr/CMakeLists.txt
@@ -4,6 +4,7 @@ if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
zephyr_library()
zephyr_library_sources(
- kscan_gpio.c
+ kscan_gpio_matrix.c
+ kscan_gpio_direct.c
)
endif()