summaryrefslogtreecommitdiff
path: root/app/drivers/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Greco <jayv.greco@gmail.com>2020-10-21 20:15:55 -0700
committerJay Greco <jayv.greco@gmail.com>2020-10-27 18:58:58 +0000
commit1522c91d73d7f35643986daa508dd7704a5f2798 (patch)
treed785b097428dcd7e9460736562c5aba3966ff92d /app/drivers/zephyr/CMakeLists.txt
parent3b9caaaf907d67dc76daa0db074aac6a8efec02a (diff)
Add new kscan_gpio_demux driver
+ zmk,kscan_gpio_demux is now a compatible kscan option + kscan_gpio_demux is based heavily off of the implementation of kscan_gpio_matrix, modified to address cols using an n-to-1 demultiplexer chip instead of discrete IO + Added zmk,kscan_gpio_demux.yaml file * modified CMakeLists to include new source files
Diffstat (limited to 'app/drivers/zephyr/CMakeLists.txt')
-rw-r--r--app/drivers/zephyr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/app/drivers/zephyr/CMakeLists.txt b/app/drivers/zephyr/CMakeLists.txt
index fc43fb8..e3a192d 100644
--- a/app/drivers/zephyr/CMakeLists.txt
+++ b/app/drivers/zephyr/CMakeLists.txt
@@ -5,6 +5,7 @@ if(CONFIG_ZMK_KSCAN_GPIO_DRIVER)
zephyr_library_sources(
kscan_gpio_matrix.c
kscan_gpio_direct.c
+ kscan_gpio_demux.c
)
zephyr_library_sources_ifdef(CONFIG_EC11 ec11.c)