summaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-08-06 10:32:06 -0400
committerPete Johanson <peter@peterjohanson.com>2020-08-06 10:32:06 -0400
commitf83ec5ce2b04380158299c20c603c1fbb49b12d6 (patch)
tree61694b8adf3635bdd083f781eb30dc9b25da798a /app/CMakeLists.txt
parent9233ab60cda263b5286ffc9edef8c8cd40cc5c0e (diff)
Refactor to using .keymap files
* Still just devicetree keymaps. * Filename can now use `<board>.keymap` or `<shield>.keymap` convention, including overrides for revisions, etc.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index b05d16b..d0d343b 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -18,10 +18,6 @@ include(cmake/zmk_config.cmake)
find_package(Zephyr REQUIRED HINTS ../zephyr)
project(zmk)
-if(EXISTS ${KEYMAP_DIR}/keymap.c)
- target_sources(app PRIVATE ${KEYMAP_DIR}/keymap.c)
-endif()
-
zephyr_linker_sources(RODATA include/linker/zmk-events.ld)
# Add your source file to the "app" target. This must come after