summaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Johanson <peter@peterjohanson.com>2020-06-13 16:37:31 -0400
committerPete Johanson <peter@peterjohanson.com>2020-06-14 23:58:43 -0400
commit583839afce4b8117e3ae7bd644954b03d0ed3ddf (patch)
treeb6faa1680d16c6702c981603442bf12e15b4e139 /app/CMakeLists.txt
parent500232bb83f5eee6815b140f6ca546fef2172f3b (diff)
Initial refactor to have a shield/board have one default keymap.
* Start of work of focusing on out-of-tree user keymaps. Add ZMK_CONFIG support. * General external configuration supported via ZMK_CONFIG, which should point to a configuration directory. * Priority order of overlay files to select. * ${SHIELD}_${BOARD}.overlay * ${SHIELD}.overlay * ${BOARD}.overlay * default.overlay * Equivalent search order for .conf files for initial Kconfig values.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index c5868ee..ed2c28c 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -12,9 +12,9 @@ list(APPEND ZEPHYR_EXTRA_MODULES
)
list(APPEND SYSCALL_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/drivers/zephyr)
-include(cmake/keymap.cmake)
+include(cmake/zmk_config.cmake)
-find_package(Zephyr)
+find_package(Zephyr REQUIRED HINTS ../zephyr)
project(zmk)