summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index f88dd9f80..6fe6f6f29 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -382,6 +382,26 @@ executable(
)
#
+# Tag
+#
+
+if chromaprint_dep.found()
+ executable(
+ 'RunChromaprint',
+ 'RunChromaprint.cxx',
+ '../src/Log.cxx',
+ '../src/LogBackend.cxx',
+ include_directories: inc,
+ dependencies: [
+ decoder_glue_dep,
+ input_glue_dep,
+ archive_glue_dep,
+ chromaprint_dep,
+ ],
+ )
+endif
+
+#
# Decoder
#