summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 71e1ae550..32cc84b44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@ noinst_LIBRARIES = \
libpcm.a \
libbasic.a \
libconf.a \
+ libsong.a \
libtag.a \
libinput.a \
libfs.a \
@@ -53,6 +54,7 @@ src_mpd_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(OUTPUT_LIBS) \
+ libsong.a \
$(TAG_LIBS) \
$(FILTER_LIBS) \
$(ENCODER_LIBS) \
@@ -168,7 +170,6 @@ libmpd_a_SOURCES = \
src/queue/Listener.hxx \
src/PluginUnavailable.hxx \
src/ReplayGainGlobal.cxx src/ReplayGainGlobal.hxx \
- src/DetachedSong.cxx src/DetachedSong.hxx \
src/LocateUri.cxx src/LocateUri.hxx \
src/SongUpdate.cxx \
src/SongLoader.cxx src/SongLoader.hxx \
@@ -184,7 +185,6 @@ libmpd_a_SOURCES = \
src/TimePrint.cxx src/TimePrint.hxx \
src/mixer/Volume.cxx src/mixer/Volume.hxx \
src/Chrono.hxx \
- src/SongFilter.cxx src/SongFilter.hxx \
src/PlaylistFile.cxx src/PlaylistFile.hxx
if ENABLE_CURL
@@ -218,7 +218,6 @@ libmpd_a_SOURCES += \
src/command/StorageCommands.cxx src/command/StorageCommands.hxx \
src/command/DatabaseCommands.cxx src/command/DatabaseCommands.hxx \
src/db/Count.cxx src/db/Count.hxx \
- src/db/LightSong.cxx src/db/LightSong.hxx \
src/db/LightDirectory.hxx \
src/db/update/UpdateDomain.cxx src/db/update/UpdateDomain.hxx \
src/db/update/Config.cxx src/db/update/Config.hxx \
@@ -1026,6 +1025,13 @@ libconf_a_SOURCES = \
src/config/Domain.cxx src/config/Domain.hxx \
src/config/Option.hxx
+# the Song library
+
+libsong_a_SOURCES = \
+ src/song/DetachedSong.cxx src/song/DetachedSong.hxx \
+ src/song/Filter.cxx src/song/Filter.hxx \
+ src/song/LightSong.cxx src/song/LightSong.hxx
+
# tag plugins
libtag_a_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -1917,11 +1923,11 @@ noinst_PROGRAMS += test/read_mixer
endif
test_ParseSongFilter_LDADD = \
+ libsong.a \
$(TAG_LIBS) \
$(ICU_LDADD) \
libutil.a
test_ParseSongFilter_SOURCES = \
- src/SongFilter.cxx \
test/ParseSongFilter.cxx
test_read_conf_LDADD = \
@@ -1945,6 +1951,7 @@ if ENABLE_DATABASE
test_DumpDatabase_LDADD = \
$(DB_LIBS) \
+ libsong.a \
$(TAG_LIBS) \
libconf.a \
libevent.a \
@@ -1964,9 +1971,7 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/AudioParser.cxx \
src/pcm/SampleFormat.cxx \
src/SongSave.cxx \
- src/DetachedSong.cxx \
- src/TagSave.cxx \
- src/SongFilter.cxx
+ src/TagSave.cxx
test_DumpDatabase_CPPFLAGS = $(AM_CPPFLAGS)
if ENABLE_UPNP
@@ -2117,8 +2122,7 @@ test_dump_playlist_LDADD = \
test_dump_playlist_SOURCES = test/dump_playlist.cxx \
src/Log.cxx src/LogBackend.cxx \
src/TagSave.cxx \
- src/TagFile.cxx \
- src/DetachedSong.cxx
+ src/TagFile.cxx
if ENABLE_FLAC
test_dump_playlist_SOURCES += \
@@ -2141,7 +2145,6 @@ test_run_decoder_LDADD = \
libutil.a
test_run_decoder_SOURCES = test/run_decoder.cxx \
test/DumpDecoderClient.cxx test/DumpDecoderClient.hxx \
- src/DetachedSong.cxx \
src/Log.cxx src/LogBackend.cxx \
src/ReplayGainInfo.cxx
@@ -2160,7 +2163,6 @@ test_read_tags_LDADD = \
libsystem.a \
libutil.a
test_read_tags_SOURCES = test/read_tags.cxx \
- src/DetachedSong.cxx \
src/Log.cxx src/LogBackend.cxx \
src/ReplayGainInfo.cxx
@@ -2191,7 +2193,6 @@ test_ContainerScan_LDADD = \
libsystem.a \
libutil.a
test_ContainerScan_SOURCES = test/ContainerScan.cxx \
- src/DetachedSong.cxx \
src/SongSave.cxx src/TagSave.cxx \
src/Log.cxx src/LogBackend.cxx \
src/ReplayGainInfo.cxx \
@@ -2453,7 +2454,6 @@ if ENABLE_DATABASE
test_test_translate_song_SOURCES = \
src/playlist/PlaylistSong.cxx \
src/PlaylistError.cxx \
- src/DetachedSong.cxx \
src/SongLoader.cxx \
src/LocateUri.cxx \
src/Log.cxx \
@@ -2483,7 +2483,6 @@ test_test_protocol_LDADD = \
test_test_queue_priority_SOURCES = \
src/queue/Queue.cxx \
- src/DetachedSong.cxx \
test/test_queue_priority.cxx
test_test_queue_priority_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS)
test_test_queue_priority_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations