summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index dd0f1a3e3..2ee505f96 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -506,10 +506,14 @@ endif
FS_LIBS = libfs.a
libfs_a_SOURCES = \
- src/fs/output/OutputStream.hxx \
- src/fs/output/StdoutOutputStream.hxx \
- src/fs/output/FileOutputStream.cxx src/fs/output/FileOutputStream.hxx \
- src/fs/output/BufferedOutputStream.cxx src/fs/output/BufferedOutputStream.hxx \
+ src/fs/io/Reader.hxx \
+ src/fs/io/FileReader.cxx src/fs/io/FileReader.hxx \
+ src/fs/io/BufferedReader.cxx src/fs/io/BufferedReader.hxx \
+ src/fs/io/TextFile.cxx src/fs/io/TextFile.hxx \
+ src/fs/io/OutputStream.hxx \
+ src/fs/io/StdoutOutputStream.hxx \
+ src/fs/io/FileOutputStream.cxx src/fs/io/FileOutputStream.hxx \
+ src/fs/io/BufferedOutputStream.cxx src/fs/io/BufferedOutputStream.hxx \
src/fs/Domain.cxx src/fs/Domain.hxx \
src/fs/Limits.hxx \
src/fs/Traits.cxx src/fs/Traits.hxx \
@@ -517,7 +521,6 @@ libfs_a_SOURCES = \
src/fs/Charset.cxx src/fs/Charset.hxx \
src/fs/Path.cxx src/fs/Path.hxx \
src/fs/AllocatedPath.cxx src/fs/AllocatedPath.hxx \
- src/fs/TextFile.cxx src/fs/TextFile.hxx \
src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/CheckFile.cxx src/fs/CheckFile.hxx \
@@ -526,7 +529,7 @@ libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
if HAVE_ZLIB
libfs_a_SOURCES += \
- src/fs/output/GzipOutputStream.cxx src/fs/output/GzipOutputStream.hxx
+ src/fs/io/GzipOutputStream.cxx src/fs/io/GzipOutputStream.hxx
FS_LIBS += $(ZLIB_LIBS)
endif
@@ -1497,8 +1500,8 @@ endif
test_read_conf_LDADD = \
libconf.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_read_conf_SOURCES = \
@@ -1521,8 +1524,8 @@ test_DumpDatabase_LDADD = \
libconf.a \
libutil.a \
libevent.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
$(ICU_LDADD) \
$(GLIB_LIBS)
test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
@@ -1552,8 +1555,8 @@ test_run_input_LDADD = \
libutil.a \
libevent.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.cxx \
test/stdbin.h \
@@ -1602,8 +1605,8 @@ test_visit_archive_LDADD = \
libutil.a \
libevent.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
$(GLIB_LIBS)
test_visit_archive_SOURCES = test/visit_archive.cxx \
src/Log.cxx src/LogBackend.cxx \
@@ -1648,8 +1651,8 @@ test_dump_playlist_LDADD = \
libconf.a \
libevent.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
libpcm.a \
$(GLIB_LIBS)
@@ -1678,8 +1681,8 @@ test_run_decoder_LDADD = \
libconf.a \
libevent.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.cxx \
@@ -1703,8 +1706,8 @@ test_read_tags_LDADD = \
libconf.a \
libevent.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.cxx \
@@ -1728,8 +1731,8 @@ endif
test_run_filter_LDADD = \
$(FILTER_LIBS) \
libconf.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_run_filter_SOURCES = test/run_filter.cxx \
@@ -1756,8 +1759,8 @@ test_run_encoder_LDADD = \
libconf.a \
libpcm.a \
libthread.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
endif
@@ -1778,8 +1781,8 @@ test_test_vorbis_encoder_LDADD = $(MPD_LIBS) \
$(PCM_LIBS) \
$(TAG_LIBS) \
libconf.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
endif
@@ -1864,8 +1867,8 @@ test_read_mixer_LDADD = \
$(OUTPUT_LIBS) \
libconf.a \
libevent.a \
- libsystem.a \
$(FS_LIBS) \
+ libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_read_mixer_SOURCES = test/read_mixer.cxx \