summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-08-10 18:06:50 +0200
committerMax Kellermann <max@musicpd.org>2018-10-24 10:52:45 +0200
commit30e22b753b06660d888eb42a8c74d950d044d6dd (patch)
tree3f19a698a757949c4562bf1b8b7f08e6df151dbd /test/meson.build
parentf7141c920121e9c6cef6582c89a73da74b814e2e (diff)
tag/Chromaprint: OO wrapper for a ChromaprintContext
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index f88dd9f80..6fe6f6f29 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -382,6 +382,26 @@ executable(
)
#
+# Tag
+#
+
+if chromaprint_dep.found()
+ executable(
+ 'RunChromaprint',
+ 'RunChromaprint.cxx',
+ '../src/Log.cxx',
+ '../src/LogBackend.cxx',
+ include_directories: inc,
+ dependencies: [
+ decoder_glue_dep,
+ input_glue_dep,
+ archive_glue_dep,
+ chromaprint_dep,
+ ],
+ )
+endif
+
+#
# Decoder
#