summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFrançois Revol <revol@free.fr>2019-03-26 23:13:54 +0100
committerMax Kellermann <max@musicpd.org>2019-03-29 14:32:59 +0100
commitcde93480099454b46cc5398c4f1cd4bd4b44062a (patch)
treeaf62707a2fbce0d46751d8568fa6061e50ad1669 /meson.build
parent095e6e6ad4808650a5bc6fe0a969de3c491353bc (diff)
Haiku: fix adding resources
The custom_command was run in src/haiku/ and created a file with only resources inside. Since xres edits the file in-place and meson doesn't like it, we have to run a shell script for now. Maybe later I'll add proper support in meson.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 12 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2133c56ed..203191c80 100644
--- a/meson.build
+++ b/meson.build
@@ -390,6 +390,7 @@ more_deps = []
if is_android
subdir('src/java')
target_type = 'shared_library'
+ target_name = 'mpd'
link_args += [
'-Wl,--no-undefined,-shared,-Bsymbolic',
'-llog',
@@ -401,16 +402,18 @@ if is_android
]
elif is_haiku
target_type = 'executable'
+ target_name = 'mpd.nores'
link_args += [
'-lnetwork',
'-lbe',
]
else
target_type = 'executable'
+ target_name = 'mpd'
endif
mpd = build_target(
- 'mpd',
+ target_name,
sources,
target_type: target_type,
include_directories: inc,
@@ -449,6 +452,14 @@ endif
if is_haiku
subdir('src/haiku')
+ custom_target(
+ 'mpd',
+ output: 'mpd',
+ input: [mpd, rsrc],
+ command: [addres, '@OUTPUT@', '@INPUT0@', '@INPUT1@'],
+ install: true,
+ install_dir: get_option('bindir'),
+ )
endif
configure_file(output: 'config.h', configuration: conf)