summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-10-31 19:30:01 +0100
committerMax Kellermann <max@musicpd.org>2018-10-31 19:30:01 +0100
commitba25a5388eb11a0570cb6ee53fc31d69f1153379 (patch)
treeaa63b14bca72675518bcbc817da756f30885df45 /meson.build
parent657ef4851829c594395c7807fdb1b73e54fbd041 (diff)
meson.build: use -funwind-tables only with clang
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8d85d1c31..0239f3316 100644
--- a/meson.build
+++ b/meson.build
@@ -60,11 +60,13 @@ test_cxxflags = test_common_flags + [
# in C++17 because the exception specification is part of a function
# type"
'-Wno-noexcept-type',
+]
+if compiler.get_id() == 'clang'
# Workaround for clang bug
# https://bugs.llvm.org/show_bug.cgi?id=32611
- '-funwind-tables',
-]
+ test_cxxflags += '-funwind-tables'
+endif
test_cflags = test_common_flags + [
'-Wmissing-prototypes',