summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-10-30 13:33:10 +0100
committerMax Kellermann <max@musicpd.org>2018-10-30 13:33:10 +0100
commit2c388434dd54418df4280c66e7fc4d5b3f5bb93e (patch)
treefc5661e24198c07e07e7baccc72fb752029a2945 /meson.build
parentc97469283c12949543193446a2e7832abc6c362e (diff)
meson.build: re-add -funwind-tables which got lost in v0.20.23 merge
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 44a1db6a4..534453f5d 100644
--- a/meson.build
+++ b/meson.build
@@ -60,6 +60,10 @@ test_cxxflags = test_common_flags + [
# in C++17 because the exception specification is part of a function
# type"
'-Wno-noexcept-type',
+
+ # Workaround for clang bug
+ # https://bugs.llvm.org/show_bug.cgi?id=32611
+ '-funwind-tables',
]
test_cflags = test_common_flags + [