summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-11-04 12:31:49 +0100
committerMax Kellermann <max@musicpd.org>2018-11-04 12:31:49 +0100
commit10ec478a9c79a222ed739efa9e1abc151ce3d56b (patch)
treea4a764fd948c191dfb9937810133feb7046458c4 /meson.build
parent86f1074905ffce25ff5d8e74fc5701f24b36823b (diff)
meson.build: refuse to build with buggy Boost version 1.67
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5d15133d5..7a747c18f 100644
--- a/meson.build
+++ b/meson.build
@@ -172,6 +172,11 @@ inc = include_directories(
)
boost_dep = dependency('boost', version: '>= 1.58')
+if boost_dep.version() == '1.67'
+ # https://github.com/MusicPlayerDaemon/MPD/pull/384
+ # https://github.com/boostorg/lockfree/commit/12726cda009a855073b9bedbdce57b6ce7763da2
+ error('Your Boost version 1.67 is known to be buggy, and the MPD build will fail. Please upgrade to Boost 1.68 or later.')
+endif
sources = [
version_cxx,