summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-11-04 12:45:22 +0100
committerMax Kellermann <max@musicpd.org>2018-11-04 12:45:22 +0100
commit08e41e60e52d5013a3a1900cdcf25371693840ff (patch)
treedaa10a2476092738e58262b853efe064ea8be5f0 /meson.build
parent10ec478a9c79a222ed739efa9e1abc151ce3d56b (diff)
meson.build: downgrade Boost 1.67 error to warning
Some Boost 1.67 packages apparently have a workaround for the bug, so let them build MPD.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7a747c18f..317284c00 100644
--- a/meson.build
+++ b/meson.build
@@ -175,7 +175,7 @@ boost_dep = dependency('boost', version: '>= 1.58')
if boost_dep.version() == '1.67'
# https://github.com/MusicPlayerDaemon/MPD/pull/384
# https://github.com/boostorg/lockfree/commit/12726cda009a855073b9bedbdce57b6ce7763da2
- error('Your Boost version 1.67 is known to be buggy, and the MPD build will fail. Please upgrade to Boost 1.68 or later.')
+ warning('Your Boost version 1.67 is known to be buggy, and the MPD build will fail. Please upgrade to Boost 1.68 or later.')
endif
sources = [