summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2021-05-25 21:05:57 +0200
committerMax Kellermann <max@musicpd.org>2021-05-25 21:06:55 +0200
commit02502514f68197925ac155ff62b59b00b18dd450 (patch)
tree6e897fcf703839c75190af72dc616e909d5a3125 /meson.build
parent1bc02123f901e141f84ff484bf90bafdbe770c28 (diff)
meson.build: require clang 7 (remove bug workaround)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 7806d837b..b9b77ce76 100644
--- a/meson.build
+++ b/meson.build
@@ -24,8 +24,8 @@ c_compiler = meson.get_compiler('c')
if compiler.get_id() == 'gcc' and compiler.version().version_compare('<8')
warning('Your GCC version is too old. You need at least version 8.')
-elif compiler.get_id() == 'clang' and compiler.version().version_compare('<5')
- warning('Your clang version is too old. You need at least version 5.')
+elif compiler.get_id() == 'clang' and compiler.version().version_compare('<7')
+ warning('Your clang version is too old. You need at least version 7.')
endif
version_conf = configuration_data()
@@ -79,12 +79,6 @@ test_cxxflags = test_common_flags + [
'-Wno-non-virtual-dtor',
]
-if compiler.get_id() == 'clang'
- # Workaround for clang bug
- # https://bugs.llvm.org/show_bug.cgi?id=32611
- test_cxxflags += '-funwind-tables'
-endif
-
test_cflags = test_common_flags + [
'-Wmissing-prototypes',
'-Wshadow',