summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-13 20:30:58 +0100
committerMax Kellermann <max@duempel.org>2009-01-13 23:08:54 +0100
commit9f21cb9dda22d0c589b41acfd04da1a1969d68da (patch)
treeacd7a4eb8533474e4e044133ed4e213327809073 /configure.ac
parenteee8bba78de8eba50f7cc7ca828ca06ed89c5893 (diff)
configure.ac: detect libid3tag without pkg-config
libid3tag comes without a pkg-config file, and it is usually added by distribution packages. For those without .pc file, attempt to auto-detect the library with AC_CHECK_LIB.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 03212e1c5..f0973ba8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -452,9 +452,14 @@ fi
AM_CONDITIONAL(HAVE_JACK, test x$enable_jack = xyes)
if test x$enable_id3 = xyes; then
- PKG_CHECK_MODULES([ID3TAG], [id3tag],
- AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag]),
- enable_id3=no)
+ PKG_CHECK_MODULES([ID3TAG], [id3tag],,
+ AC_CHECK_LIB(id3tag, id3_file_open,
+ [ID3TAG_LIBS="-lid3tag -lz" ID3TAG_CFLAGS=""],
+ enable_id3=no))
+fi
+
+if test x$enable_id3 = xyes; then
+ AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag])
fi
AM_CONDITIONAL(HAVE_ID3TAG, test x$enable_id3 = xyes)