summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2016-07-29 15:21:38 +0200
committerMax Kellermann <max@duempel.org>2016-07-29 15:21:38 +0200
commitd916890a8fcbf04528b0eedac9d3e872e421de81 (patch)
treee8854913600be4f1b5a8a88df7e56aa977d1bc39 /configure.ac
parent071cacc9a4cdb0fb9997cfe5c44a79c89dbb242b (diff)
configure.ac: detect libsidplay2 and related with pkg-config
The comment about requiring libtool from 7 years ago is obsolete these days.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 72bcc0da9..b67b5aeff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1333,9 +1333,9 @@ AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes || test x$enab
dnl --------------------------------- sidplay ---------------------------------
if test x$enable_sidplay != xno; then
- # we're not using pkg-config here
- # because libsidplay2's .pc file requires libtool
- AC_CHECK_LIB([sidplay2],[main],[found_sidplay=yes],[found_sidplay=no],[])
+ PKG_CHECK_MODULES([SIDPLAY], [libsidplay2 libsidutils],
+ [found_sidplay=yes],
+ [found_sidplay=no])
MPD_AUTO_PRE(sidplay, [sidplay decoder plugin],
[libsidplay2 not found])
@@ -1345,18 +1345,12 @@ if test x$enable_sidplay != xno; then
AC_CHECK_LIB([resid-builder], [main],
[found_sidplay=yes], [found_sidplay=no])
- if test x$found_sidplay = xyes; then
- AC_CHECK_LIB([sidutils],[main],[:],[found_sidplay=no],[])
- fi
-
MPD_AUTO_RESULT(sidplay, [sidplay decoder plugin],
- [libresid-builder or libsidutils not found])
+ [libresid-builder not found])
fi
if test x$enable_sidplay = xyes; then
- AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder -lsidutils")
- AC_SUBST(SIDPLAY_CFLAGS,)
-
+ SIDPLAY_LIBS="$SIDPLAY_LIBS -lresid-builder"
AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
fi