summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2016-05-03 12:52:30 +0200
committerMax Kellermann <max@duempel.org>2016-05-03 13:01:23 +0200
commitfb5610f9bd354a84898a8d89dfd140f3c7a9522d (patch)
tree76cd2e2d4719db74c3567e3ea2993e33fe3b5d96 /configure.ac
parent7adbd00811f4a112074f1620eef41d2b80d3c4f6 (diff)
configure.ac: improve HAVE_XIPH declaration, add HAVE_OGG
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ab98b19f8..faae616a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1011,11 +1011,6 @@ dnl --------------------------------- WildMidi --------------------------------
MPD_ENABLE_AUTO_LIB(wildmidi, WILDMIDI, WildMidi, WildMidi_Init, [-lWildMidi], [],
[WildMidi decoder plugin], [libwildmidi not found])
-dnl ------------------------ Post Decoder Plugins Tests -----------------------
-
-AM_CONDITIONAL(HAVE_XIPH,
- test x$enable_vorbis = xyes || test x$enable_tremor = xyes || test x$enable_flac = xyes || test x$enable_opus = xyes)
-
dnl ---------------------------------------------------------------------------
dnl Encoders for Streaming Audio Output Plugins
dnl ---------------------------------------------------------------------------
@@ -1258,6 +1253,23 @@ fi
AM_CONDITIONAL(ENABLE_WINMM_OUTPUT, test x$enable_winmm_output = xyes)
dnl ---------------------------------------------------------------------------
+dnl Option groups
+dnl ---------------------------------------------------------------------------
+
+have_ogg=no
+if test x$enable_vorbis = xyes || test x$enable_tremor = xyes || test x$enable_opus = xyes; then
+ have_ogg=yes
+fi
+
+have_xiph=no
+if test x$enable_ogg = xyes || test x$enable_flac = xyes; then
+ have_xiph=yes
+fi
+
+AM_CONDITIONAL(HAVE_OGG, test x$have_ogg = xyes)
+AM_CONDITIONAL(HAVE_XIPH, test x$have_xiph = xyes)
+
+dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------
if test x$enable_documentation = xyes; then