summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-06-22 19:37:18 +0200
committerMax Kellermann <max@musicpd.org>2018-06-22 19:37:18 +0200
commitd0fbf6db592eb445c9741fc7544b7bee739fcdfa (patch)
treed8cd22fa2f23dc150ef8b07f46d9561c276ee316 /Makefile.am
parent01d8eb629072e4d5d02345868f4233177c99d70a (diff)
input/Stream: remove attribute "cond", replace with handler interface
This adds a bit of overhead, but also adds flexibility to the API, because arbitrary triggers may be invoked from that virtual method implementation, not just Cond::signal(). The motivation for this is to make the handlers more dynamic, for the upcoming buffering class utilizing ProxyInputStream.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fce275360..8f3f57b7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1382,6 +1382,7 @@ libinput_a_SOURCES = \
src/input/InputStream.cxx src/input/InputStream.hxx \
src/input/Ptr.hxx \
src/input/InputPlugin.hxx \
+ src/input/Handler.hxx \
src/input/RemoteTagScanner.hxx \
src/input/ScanTags.cxx src/input/ScanTags.hxx \
src/input/Reader.cxx src/input/Reader.hxx \