summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2017-01-26 09:34:53 +0100
committerMax Kellermann <max@musicpd.org>2017-08-25 09:52:44 +0200
commitc8f7a859eafbb4e60f5c247e7fef3f3f1ab806cf (patch)
tree3571817566a84228b169af23ccabff176b4becfc /Makefile.am
parent28a2d41b85fce58d02d1205620f8f4ad1d38a2b4 (diff)
lib/upnp/Discovery: use CURL instead of UpnpDownloadUrlItem()
We can do CURL requests asynchronously, and we don't need a synchronous WorkQueue thread for that. This allows parallelizing lookups and allows immediate cancellation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 61b442b75..cd1311029 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -254,7 +254,6 @@ UPNP_SOURCES = \
src/lib/upnp/Callback.hxx \
src/lib/upnp/Util.cxx src/lib/upnp/Util.hxx \
src/lib/upnp/UniqueIxml.hxx \
- src/lib/upnp/WorkQueue.hxx \
src/lib/upnp/Action.hxx
ALSA_SOURCES = \
@@ -1784,9 +1783,14 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/DetachedSong.cxx \
src/TagSave.cxx \
src/SongFilter.cxx
+test_DumpDatabase_CPPFLAGS = $(AM_CPPFLAGS)
if ENABLE_UPNP
-test_DumpDatabase_SOURCES += src/lib/expat/ExpatParser.cxx
+test_DumpDatabase_SOURCES += \
+ $(CURL_SOURCES) \
+ src/lib/expat/ExpatParser.cxx
+test_DumpDatabase_CPPFLAGS += $(CURL_CFLAGS)
+test_DumpDatabase_LDADD += $(CURL_LIBS)
endif
test_run_storage_LDADD = \